标签:php-fpm

LNMP 卡在 starting PHP-FPM 解决办法

今晚在阿里云使用LNMP一键安装包安装Nginx环境,安装完成后,在启动服务的时候出现界面卡在“starting PHP-FPM”,此问题造成的原因很复杂,其中一个可能的原因就是PHP版本太低,在5.3及以前的老版本,PHP-FPM是独立于PHP安装的,而到了PHP5.4版本以后,就集成PHP-FPM组件了,解决这一问题的办法网上有很多,通常是升级PHP到5.3.26,但我还是建议大家直接升级到5.4以后的版本,毕竟这个版本集成了FPM,不但可以解决问题,执行效率更高。 cd lnmp1.0-full ./upgrade_php.sh 去PHP官方查看官方当前的最新版本,建议大家使用官方最新版本的上一个稳定版本,比如PHP官方现在最 […]

查看更多